آموزش CCNA – درس دهم (Help sign, Show startup-config, Show running-config)


علامت ” ؟ “
ممکن است چگونگی تایپ و استفاده از ؟ برای درخواست کمک هنگام کار با IOS سیسکو مورد استفاده قرار می گیرد .

شما می توانید از این دستور در موارد بسیاری استفاده نمائید. اول, استفاده از آن زمانی که نمی دانید چه دستوری را باید تایپ کنید. برای مثال برای مشاهده لیستی از دستورات ممکن در خط فرمان علامت ؟ را تایپ کنید. هم چنین می توانید زمانی که نمی دانید پارمتر بعدی که برای یک دستور وارد شده چه عبارتی می باشد از این علامت استفاده نمائید.

برای مثال دستور  ? ip  را وارد می نماییم. همانطور که مشاهده می نمایید تمام دستوراتی که می توانند پس از IP وارد گردند را نشان می دهد.

regux(config)#ip ?
  access-list      Named access-list
  default-gateway  Specify default gateway (if not routing IP)
  dhcp             Configure DHCP server and relay parameters
  domain           IP DNS Resolver
  domain-lookup    Enable IP Domain Name System hostname translation
  domain-name      Define the default domain name
  ftp              FTP configuration commands
  host             Add an entry to the ip hostname table
  name-server      Specify address of name server to use
  ssh              Configure ssh options

Show running-configuration

این دستور كه به‌صورت sh run هم نوشته می‌شود، پیكربندی مسیریاب، سوییچ و دیواره آتشِ سخت‌افزاری شبكه‌ در حال كار را نمایش می‌دهد. این دستور به‌صورت یك فایل ‌‌config در حافظه‌ مسیریاب موجود است. شما با تغییراتی كه در روتر ایجاد می‌كنید، باعث تغییر در این فایل خواهید شد. فراموش نكنید تا زمانی‌كه به‌وسیله دستور copy running-configuration startup-configuration فایل را ذخیره نكرده‌اید، تغییراتِ انجام شده ثبت نخواهد شد.‌

regux#show running-config 
Building configuration...

Current configuration : 1036 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname regux
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

نکته: به صورت پیشفرض دستورات show در محیط privileged exec mode قابل اجرا می باشد. لازم به ذکر است در محیط global configuration mode نیز با قرار دادن کلمه do به ابتدای دستورات مجاز محیط privileged exec mode، می توان آنها را اجرا نمود.

به مثال ذیل توجه نمائید.

regux(config)#do sh ru
Building configuration...

Current configuration : 1036 bytes

Copy running-configuration startup-configuration

این دستور كه به صورت ‌‌copy run start هم نوشته می‌شود، پیكربندی در حال تغییر را در حافظه RAM ذخیره می‌نماید. این تغییر برای حافظه‌ مانای سیستم ‌(NVRAM) به‌عنوان پیكربندی اجرایی شناخته می‌شود. در صورت قطع شدن برق، حافظه NVRAM، از پیكربندی سیستم محافظت می‌نماید.

regux#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]
regux#

show startup-config

تنظیمات startup-configuration را نمایش می دهد.

regux#show startup-config
Using 1036 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname regux

نویسنده: آرزو اسدیان
کپی تنها با ذکر نام ریجاکس و لینک زیر مجاز است.
لینک:http://blog.regux.com/learning-course/ccna-learning/learn-ccna-lesson-10-show-startup-config-show-running-config-?-sign

 

میلاد خوشدل

در حوزه‌ی امنیت وب و شبکه فعالیت می کند، عاشق پارکور است و مدیریت دیتاسنتر، امن سازی شبکه های مخابراتی و کابلی و برنامه نویسی وب و موبایل از تجارب کاری او می باشد. او در حال حاضر بنیانگذار ریجاکس است.

  1. پاسخ

    ممنون از سایت خوبتون. من هم توی سایتمون آموزش های زیادی گداشتم به سایت من هم سر بزنید

نظر خود را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.

12 + چهارده =


تگ های html مجاز به استفاده می باشند: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

ارسال یک پیام